06 Jun, 2008, BoGy wrote in the 1st comment:
Votes: 0
Hello,i would like some assistance on a small problem i cannot solve.
The owner of the shell where i'm running my mud changed the distribution,i didnt do any changes to the mud and it used to run perfectly…now after i compile it and try to start it up it just wont start,i get an error when the code tries loading the area files :
Fri Jun 6 10:01:18 2008 :: Reading Area List.
Fri Jun 6 10:01:18 2008 :: reading social.are
Fri Jun 6 10:01:18 2008 :: reading asgardian.hlp
Fri Jun 6 10:01:18 2008 :: GAME CRASHED (SIGNAL 11).

There's nothing wrong with the files…i tried commenting asgardian.hlp file but it will just give me the same error on the next file that's trying to load…something wrong with area.lst or something :-/ Could anyone help me please?
06 Jun, 2008, Sandi wrote in the 2nd comment:
Votes: 0
Be sure your .are files all have several blank lines at the end.
06 Jun, 2008, BoGy wrote in the 3rd comment:
Votes: 0
Yes,they have…that's not the problem *shrug*
06 Jun, 2008, exeter wrote in the 4th comment:
Votes: 0
Have you tried recompiling? Since your host changed distros, that might cause some problems with shared libraries and such.
06 Jun, 2008, Asylumius wrote in the 5th comment:
Votes: 0
Verify that the last area it tried to load is formatted correctly. Scan through it and see or trying booting without it once. Try recompiling, like exeter said. You can try GDB as well, or some old fashioned logging echos to help you track down where/why its crashing.
06 Jun, 2008, BoGy wrote in the 6th comment:
Votes: 0
I did all of the above,i recompiled it…clean install…looked trough the area files…also if i startup without the first area it crashes on it will just crash on the next one and so on… :( no one can help?
06 Jun, 2008, Davion wrote in the 7th comment:
Votes: 0
If you did all of the above, please provide us with the gdb info. Might help us solve your problem.
06 Jun, 2008, BoGy wrote in the 8th comment:
Votes: 0
Im not used to using GDB….if anyone could help me use it i would appreciate it…
06 Jun, 2008, BoGy wrote in the 9th comment:
Votes: 0
Ok …one more thing i think my startup is fucked up….not compatibile with this debian version or something…if i start it manually by using ./rot (port) & it works perfectly…
Uhh…this is the startup file :
#! /bin/csh

set areapath = /muds/nightmare/bogy/rot1/area
set port = 4949
set wwwport = 4950

cd $areapath

if ( -e shutdown.txt ) rm -f shutdown.txt

while ( 1 )
# If you want to have logs in a different directory,
# change the 'set logfile' line to reflect the directory name.
set index = 1000
while ( 1 )
set logfile = ../log/$index.log
if ( ! -e $logfile ) break
@ index++

# Copy rot binary from bin directory.
# after a compile, place the new binary in the bin directory,
# this way a reboot will install the new binary, instead of
# of having to shut down.
# rm -f ./rot
# cp ../src/rot .

# Get a list of rot processes currently running
# This will be necessary to keep the script from trying to run rot
# every 20 seconds and creating excess logfiles.
set procs = (`/bin/ps ax | grep "rot $port"`)

# In order to keep the grep we just ran from giving a false
# positive, we check the 5th argument to see if it is the rot
# process that we ran and not grep.
# We use the 5th element because on the format of 'ps ax'
if ( $#procs >= 5 ) then
set command = "$procs[5]"
set command = "BLARG!"

if ( "$command" != '../src/rot' ) then
# Run rot.
../src/rot $port $wwwport >&! $logfile

# Restart, giving old connections a chance to die.
if ( -e shutdown.txt ) then
rm -f shutdown.txt
exit 0
sleep 20
06 Jun, 2008, Asylumius wrote in the 10th comment:
Votes: 0
Make sure the directory structure is right. You have:
set areapath = /muds/nightmare/bogy/rot1/area

Is that the correct full path to the area folder?

Also make sure that csh is located in bin, like you specify:
#! /bin/csh
07 Jun, 2008, BoGy wrote in the 11th comment:
Votes: 0
I figured out the problem…it was the rot file i had in /src , it was corrupted,broken something…i copied the one i had in /area over it and it works …