09 Jun, 2009, Metsuro wrote in the 1st comment:
Votes: 0
Anyone have success in getting Nick Gammons lua examples and such to work well within 1.9 yet? I know Nick himself changed it around to get it working in 1.8 just wanted to know if anyone succeeded in adding it to 1.9
09 Jun, 2009, tphegley wrote in the 2nd comment:
Votes: 0
Yea, it was rather simple to put it into 1.9. I believe it was pretty much just drop it in and then add in the lua calls in the appropriate files.
10 Jun, 2009, Metsuro wrote in the 3rd comment:
Votes: 0
I alright dumb question then maybe, which verison did you use to "drop in" by chance?
10 Jun, 2009, Metsuro wrote in the 4th comment:
Votes: 0
Well it took awhile for me to get it going but I did get it going, expect now once it goes all the way through I get this… /usr/bin/ld: cannot find -llua… Does this mean it cant find it and I might possibly need a local copy? or is this something I'd have to talk about server owners for help with this?
10 Jun, 2009, tphegley wrote in the 5th comment:
Votes: 0
Either or. You can make your own local lua folder and point to that or ask your server host to add lua and then point to that.

I used Nick's latest version of his lua files and smaugfuss 1.9.
11 Jun, 2009, Metsuro wrote in the 6th comment:
Votes: 0
I dont mean to sound like a such a dip, but…. how does one create a local copy?
11 Jun, 2009, David Haley wrote in the 7th comment:
Votes: 0
You would download the distribution from lua.org, compile it, and then install it to your home directory. Then, you point your MUD's Makefile to that directory for the Lua include and library files.
11 Jun, 2009, Metsuro wrote in the 8th comment:
Votes: 0
now the "home" directory can this be any directory? I use genesismuds as a host and they start you in a mud folder, that has everything for you so I could just do it here and point it to that still correct?
11 Jun, 2009, David Haley wrote in the 9th comment:
Votes: 0
Sure, you can install it into any directory you like. I suspect that your "mud folder" is actually what the system is using as your home folder.
I'm assuming that you have some kind of shell access to the system, right? When you log in to the shell, you should be in your home directory. If you type just "cd", it should bring you back to home.
11 Jun, 2009, Metsuro wrote in the 10th comment:
Votes: 0
Ok, so that make sense so Im still a bit limited in my knowledge of linux and such. How would one install it from this point, get a copy for lua.org and make local to use as a private copy? then how would I point the makefile to this copy? Thanks for the help by the way.
11 Jun, 2009, David Haley wrote in the 11th comment:
Votes: 0
You would need to go to lua.org and download their latest release, and then move that archive to the server. Alternatively, you can do something like (on the server)
wget url
where "url" is the link of the archive.

You need to expand the archive (typically, 'tar -xzf archive' if it's a .tgz file), and then read the compilation instructions. After building it, you need to copy the include files and library files (it will tell you what those are in the documentation somewhere, IIRC) to a known location on your server. (All of this is happening on your server, btw.) Once you're done with all that, you can edit your makefile to have it point to the local installation like tphegley suggested.

That said, it might be easier to just talk to the sysadmin and ask them to install it system-wide, because that is likely to be a lot easier if you're not comfortable with this kind of thing.
11 Jun, 2009, Metsuro wrote in the 12th comment:
Votes: 0
Well the problem I noticed that I can just log in and open up lua on the server they have 5.1.2 but I just cant use the -llua flag I guess? and I've gotten a decent amount of way on this just dont really know how to point it to the local copy correctly I guess?
11 Jun, 2009, David Haley wrote in the 13th comment:
Votes: 0
Oh… you probably don't need a local copy. You just need to tell your compiler where Lua is…

It's probably in /usr/lib/lua, or /usr/lib/lua5.1, or something like that. You might have to poke around a bit. Then, in your makefile, add "-Lpath" to the linker flags (LFLAGS typically), and you should be set.