07 Feb, 2009, rendo wrote in the 1st comment:
Votes: 0
I've ALWAYS noticed mpsleep was VERY buggy with programs. I'm using a modified DBSC2.5 codebase, so maybe there's a snippet to fix mpsleep, I haven't checked yet.

Basically. If an mpsleep if used before or after an if or else check in a program, the program tends to not work. So most of the time I just avoid using mpsleeps in those situations and the programs work fine. Now I'm having a new problem.

if carryingvnum($n) == 20221
say Why haven't you left yet? Who knows what they're doing to him in that musty old tower!
if carryingvnum($n) == 20220
sa Wow! That medal belongs to the mayor, have you seen him? You should go to his hut and see if he's returned.
mpsleep 10
sa Oh, I'm sorry I didn't see you there. Everyone has just been so worried lately.
mpsleep 4
sa The mayor of Penguin Village has been taken captive by the Red Ribbon Army. They're forcing our people to work hunting for dragonballs .
mpsleep 4
emot takes a sip of her hot chocolate.
mpsleep 4
sa My daddy is gone too…the only way to save us all is to save the mayor. He's being held in muscle tower.
mpsleep 4
sa You look like someone who could help, here take this.
oinvoke 20221
give hat $n
mpsleep 3
sa Give this to the mayor if you find him, he'll know you're okay.

The program is setup properly, and it's a greet program. If you enter the room with either of the items, the program works as it should. But if you DON'T have the items ALL she does is sigh. What irritates me the most is that after I FIRST put her program in, it worked the VERY first time. Now it doesn't. I'm baffled, I need to know if anyone else has experienced this, how they fixed it, what I can do to avoid this again, etc.

Apparently there's a snippet that fixes the else issues, I'm going to install that and see what happens.
07 Feb, 2009, Zeno wrote in the 2nd comment:
Votes: 0
There are a number of mpsleep fixes around. Check gammon.com.au and snippet sections.

Example: http://www.gammon.com.au/forum/bbshowpos...
07 Feb, 2009, Ssolvarain wrote in the 3rd comment:
Votes: 0
I see a lot of typos in there…
07 Feb, 2009, rendo wrote in the 4th comment:
Votes: 0
What typos?

Uh… Okay. If you hotboot and try the program it works, JUST ONCE. After that it doesn't work again. So I have NO idea what's going on. Have applied the mpsleep2.0 fix, or at least I'm pretty sure it's all in, so I'm confused. :/