29 Jan, 2009, Kayle wrote in the 1st comment:
Votes: 0
For those of you using the latest version of the IMC2 Freedom client, have you noticed any oddities with it maybe failing to recognize valid socials?
29 Jan, 2009, Omega wrote in the 2nd comment:
Votes: 0
Nope, but I have noticed that when it shutdowns, it doesn't appear to clear our all the memory it allocated.

Appears like I'm going to have to glare angrily at it to get a clean shutdown with valgrind.

As everytime I edit the imc.c file, it complains the next compile about the multibyte characters used, and then doesn't read the files correctly.. and yeah..

(growls angrily)

Anywho, thats just me.
29 Jan, 2009, Kayle wrote in the 3rd comment:
Votes: 0
It just randomly starts ignoring the socials that work fine in the mud but then IMC tells you that it's not a valid social. And it's.. wierd. A hotboot fixes the issue though, so I dunno.
29 Jan, 2009, Omega wrote in the 4th comment:
Votes: 0
I haven't encountered it yet, though I don't use the IMC as often as I used to. I'd look into it further personally, but as I said above, as soon as I change anything in the imc.c file, anything at all, and hit save, I lose my IMC. Which is really annoying, not sure if its changing the file's format or what-not, but its driving me nuts. Nomatter what editor is used. You could simply press enter and save. That extra line of whitespace causes it to crap out complaining.

So I'm not even going to start on the socials until I can get past the redunkulas issue with not being able to change anything.
29 Jan, 2009, Kayle wrote in the 5th comment:
Votes: 0
That is a bit odd.
29 Jan, 2009, Kline wrote in the 6th comment:
Votes: 0
Darien said:
Nope, but I have noticed that when it shutdowns, it doesn't appear to clear our all the memory it allocated.

Are you talking about on game shutdown? If so, I've already crossed that bridge with IMC, so I'll save you some effort :P

Call free_imcdata(true), but that's not all! free_imcdata() itself also was missing a call out for (true), so beneath
if( complete )
ensure that both
imc_delete_templates(); imc_delete_info();
are present.
29 Jan, 2009, Omega wrote in the 7th comment:
Votes: 0
thats good to know. Will help me get to fix the memory on complete game-shutdown (trying to valgrind for memory leaks, and IMC is the only thing I see cuz its not emptying out)

But at the same time. I cannot edit the .c file without completely losing the ability for it to work properly again.

Note: it complains about the use of the multibyte character, and then all files it reads in that use the multibyte character for parsing, load improperly. So this is a mixed set of nuts I have to deal with.

So samson, if ur out there, is the file saved in some super-funky format?

Cannot nano it. pico, joe, kdevelop, jedit, kedit, kate, editpad, ultraedit, wordpad, notepad, vi, nothing, nomatter what I edit it with, as soon as I hit save. it fails to work. Which = VERY annoying.

29 Jan, 2009, David Haley wrote in the 8th comment:
Votes: 0
I've never had that kind of trouble editing imc.c… I use vim.
29 Jan, 2009, Zeno wrote in the 9th comment:
Votes: 0
Yeah, sounds like that's something funky going on there with your keyboard/server.
29 Jan, 2009, Omega wrote in the 10th comment:
Votes: 0
I must just be lucky.

I'd assume its the keyboard, except that it happens nomatter what terminal I do it on.

Including in my account on Samson's server. Could be something funky going on.

But as soon as I edit something, all the lines where it has the funky questionmark (multibyte character) give warnings in the code, and then files don't load properly.

In anycase. Its all good, I'm assuming its something that is going on between computer and the server, or vice versa. Who knows right (prods laptop)

Both using Fc10, so I'm unsure as to why its funk'n out on me. Could be because my keyboard is set to canadian english apposed to US english. Oi… The joys of multibyte characters.
29 Jan, 2009, Kayle wrote in the 11th comment:
Votes: 0
Wait. What funky questionmark character?
29 Jan, 2009, David Haley wrote in the 12th comment:
Votes: 0
Could you maybe give line references so we know where these characters are showing up?
29 Jan, 2009, Omega wrote in the 13th comment:
Votes: 0
It looks like a funky questionmark on my system.. And yeah, una-momento, I'll track them down.

imc.c:4221:75: warning: multi-character character constant
imc.c:4860:69: warning: multi-character character constant
imc.c:4867:69: warning: multi-character character constant
imc.c:4874:69: warning: multi-character character constant
imc.c:4881:69: warning: multi-character character constant
imc.c:4888:69: warning: multi-character character constant
imc.c:4895:69: warning: multi-character character constant
imc.c:4902:69: warning: multi-character character constant

Anytime I edit imc.c Those warnings appear instantly, nomatter *WHAT* I edit even if its just literaly adding an empty whitespace at the bottom of the file.
29 Jan, 2009, Zeno wrote in the 14th comment:
Votes: 0
What if you touch imc.c without editing?
29 Jan, 2009, Omega wrote in the 15th comment:
Votes: 0
I haven't tried to use touch on it yet. I may do that when I get home from work.

I'm really unsure about why its doing this to me. I think it hates me.
29 Jan, 2009, Kayle wrote in the 16th comment:
Votes: 0
Those look like they're all single quotes. Unless there's something different about your file and mine. Could you be referring to the cents symbol? (if so your line numbers and mine are off by a few.)
29 Jan, 2009, Omega wrote in the 17th comment:
Votes: 0
If they are cents symbols, groovey, they show up as a question mark for me., funky at that, background coloured with the shape a questionmark in it.

And if the line-numbers are off, then I dunno, thats what the compiler spits out at me. Though I had to dig those up from a post I made afew months ago. Seeing as I'm at work I don't have access to my code to get the exact warnings, though those are it, but the line numbers could be skewed because I had edited the file in the version I posted about before.

But same issue then as now, I ended up putting the old version back ontop of it, and hadn't touched it sense because it kept repeating that warning and screwing up the files.
30 Jan, 2009, Grimble wrote in the 18th comment:
Votes: 0
I'm guessing here, but maybe you're hitting the old problem of DOS vs. UNIX text file format.

Try running the dos2unix command on the file…

> dos2unix imc.c
30 Jan, 2009, Omega wrote in the 19th comment:
Votes: 0
I've already exhausted things like that. They appear not to work. Preserving the Unix format was the first thought I had. But it did not prevent the issue from continuing.

I started wondering if it would be in another format like UTF-18 or whatever its called. Which is often used when handling Unicode. It failed to work aswell. I ran through about 30 different types and then gave up. No point in making my brain hurt more.

Figure'd if anything, I'd just leave it-be, and if it got to the point where I needed todo something with it, I'd just convert the funky symbol to a tilde and say to hell with the redunkulas nature that is the problem.

Which may be the route I end up going unfortunatly. But once again. When I get home from work, I'll try out afew things and see how they pan out. Hopefully they will result in a working IMC change.

I'd really like to convert my descriptors to stl, while maintaining the functionality of my IMC. I'd rather not abandon the IMC. Its been too nice to me.

In anycase, good idea Grimble. Unfortunatly I've already tried.
30 Jan, 2009, quixadhal wrote in the 20th comment:
Votes: 0
If it is a cent symbol, that shouldn't be done as a straight-up character constant, because it's extended ASCII (162) and won't work right across locale boundaries. If you really want that symbol to be used, it should probably be as (char)162 specifically.

For the short term, you could use sed or something to replace those symbols with something your editor won't barf on and then see about tidying it up later.

Maybe sed 's!\xa2!X!g' ?

That's my only guess anyways. You might also be able to get away with changing your locale to see if your editor would be happier.