MudBytes
» MUDBytes Community » Game Creation » Server Management » nknown option '-
Pages: << prev 1 next >>
nknown option '-, bugging the heck out of me!
sweatsack
Fledgling




Group: Members
Posts: 3
Joined: May 3, 2010

Go to the bottom of the page Go to the top of the page
#1 id:45712 Posted May 4, 2010, 3:51 pm

I'm trying to get AFKmud going on a VMWare virtual machine running ArchLinux. I got the newest version (214), unpacked it, recompiled the source (I don't know if this is necessary but it seemed like a good idea) and then ran ./startup

I get the following error:

Code (text):
'nknown option: '-
usage: csh [ -bcdefilmnqstvVxX ] [ argument . . . ].


I've googled this problem and have found no satisfactory answer; I was hoping you guys could help me.

Maybe another hint...I just installed VMware and ArchLinux today. I installed it specifically for this purpose; I just want to be able to tinker while I'm rustling up some hosting and while I'm at school (where they block the telnet & ssh ports). I didn't realize how "stripped down" it was and spent a lot of time installing software by trial and error. This is OK but I've hit a lot of snags because I forgot to install this or that...could that be a problem? On the other hand everything should be the latest and greatest version because I used pacman to grab it all just this afternoon.

Thanks!

Edit: also, some other things I tried...copying the startup file from 213, rewriting the code parts of the startup file by hand (this produced other errors, but I'm not sure if this is because I fixed the error I'm asking about, or if I just created more errors "before" it), changing /bin/csh to /usr/bin/csh, /bin/tcsh, etc.

Last edited May 4, 2010, 3:54 pm by sweatsack
Tyche
Wizard






Group: Members
Posts: 2,038
Joined: May 23, 2006

Go to the bottom of the page Go to the top of the page
#2 id:45714 Posted May 4, 2010, 4:51 pm

The problem is the very first line of your startup script. 
But since you didn't post it, we cannot give an answer.
.........................
Proud member of Team Hetero
http://jlsysinc.gotdns.com/ladybug_laugh2.jpghttp://jlsysinc.gotdns.com/teensymud_250x80.pnghttp://jlsysinc.gotdns.com/palin_calendar.jpg
For now we see through a glass, darkly; but then face to face: now I know in part; but then shall I know even as also I am known.

sweatsack
Fledgling




Group: Members
Posts: 3
Joined: May 3, 2010

Go to the bottom of the page Go to the top of the page
#3 id:45715 Posted May 4, 2010, 5:40 pm

Very first line is:

Code (text):
#! /bin/csh -f

I assumed this was implied when I mentioned that this was a first install of AFKmud 214 and that I had also copied the stock startup script directly out of the 213 tar. My bad.

Last edited May 4, 2010, 5:47 pm by sweatsack
Tyche
Wizard






Group: Members
Posts: 2,038
Joined: May 23, 2006

Go to the bottom of the page Go to the top of the page
#4 id:45717 Posted May 5, 2010, 3:32 am

Try removing the -f option

or

try running the bash script instead of the c-shell script
It's called ./startup.sh



.........................
Proud member of Team Hetero
http://jlsysinc.gotdns.com/ladybug_laugh2.jpghttp://jlsysinc.gotdns.com/teensymud_250x80.pnghttp://jlsysinc.gotdns.com/palin_calendar.jpg
For now we see through a glass, darkly; but then face to face: now I know in part; but then shall I know even as also I am known.

David Haley
Wizard






Group: Members
Posts: 7,841
Joined: Jun 30, 2007

Go to the bottom of the page Go to the top of the page
#5 id:45720 Posted May 5, 2010, 7:18 am

Also, make sure you have tcsh, not just the normal csh.
.........................
-- d.c.h --
BabbleMUD Project (custom codebase)
Legends of the Darkstone (head coder)
http://david.the-haleys.org
.........................

Sillviant
Fledgling






Group: Members
Posts: 4
Joined: Jun 9, 2009

Go to the bottom of the page Go to the top of the page
#6 id:45741 Posted May 6, 2010, 4:44 pm

Actually there is nothing wrong with the -f flag.  Just need to make sure you have tcsh installed and you won't have to mess with your startup script.  The f flag just causes it to ignore any startup files for the csh shell. Which is useful for when your just wanting to use the c shell only for running a script, not as your default shell.

Pages:<< prev 1 next >>