29 Dec, 2015, Akikiki wrote in the 1st comment:
Votes: 0
I am trying to set up a TinyMUCK on my ubuntu server. When I run ./restart I get:
User@Server:~/muck/fbmuck-6.17/game$ ./restart
Restoring from delta.
Last delta is incomplete. Truncating to previous dump.
Hmm. No previous delta dump.

Any help would be GREATLY appreciated!

Post scriptum: This is my first time trying to run a MUCK server. Also, I am new to MudBytes, I apologize for any social blunders.
29 Dec, 2015, Idealiad wrote in the 2nd comment:
Votes: 0
I don't know MUCK but if it's your first start of the server then maybe you don't want a restart? Is there just a start/run command?
29 Dec, 2015, Akikiki wrote in the 3rd comment:
Votes: 0
Not that I am aware of. My understanding is that the file named 'restart' is a script that manages the MUCK (start, restart, port, etc.) and prevents more than one instance from running at a time.

Some information I forgot to add: The MUCK distribution is fbmuck-6.17. The OS is Ubuntu Server 12.04.5 LTS
29 Dec, 2015, Idealiad wrote in the 4th comment:
Votes: 0
Hmm, maybe you need a starter DB as well as the server?
30 Dec, 2015, Akikiki wrote in the 5th comment:
Votes: 0
I have std-db.db std-db.new and std-db.old, and when I didn't, I received an error saying so. I followed the COMPILING and INSTALLATION documentation. Perhaps my lack of experience with MUCKs is the issue. Any suggestions for a MU* for someone first starting out?
30 Dec, 2015, Akikiki wrote in the 6th comment:
Votes: 0
When I was digging around in restart and found this
# This is the name of the netmuck program to run. You probably don't want to
# change this unless you renamed the server program to something other than
# fbmuck.

So I decided to try running that, which gives me this:
User@Server:/usr/local/bin$ ./fbmuck std-db.db std-db.new 8000 8001s
Unable to open logs/status!
Wed Dec 30 07:47: INIT: TinyMUCK version starting.User@Server:/usr/local/bin$

I have changed the file permissions, which produces no noticeable effect. It does say
INIT: TinyMUCK version starting.
so I was hopeful, but I could not connect with my client and I when I run
ps -aux
I do not see a process for the MUCK.